question-circle Redirect back to restricted page doesn't seem to be working

More
1 year 5 months ago #11012 by arcascomputing
I'm sure this was working in the past but the action of having a user try to access a secure page and being redirected to the login page, then being taken back to the page requested after successful login no longer seems to work on our site.

I've checked as many things as I can and have followed steps laid out in your FAQS to check/remove any redirects set in login modules and pages but have had no joy. I've also checked that I'm getting the "Please login first" system message.

Can you suggest what else I can try?

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #11019 by carsten888
Have you got community builder installed?

The restricted page, is that a joomla core page or of another component?

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #11020 by arcascomputing
No, community builder isn't installed on this site.

The restricted page which was noticed the issue with was an Edocman page - example is www.delta-ee.com/downloads/2-subscribers...for-flexibility.html . After login it takes me to www.delta-ee.com/view-your-user-details.html instead of back to that page.

Another page ( www.delta-ee.com/members/my-subscriptions/connected-home.html ) is an SP PageBuilder page and this seems to redirect back to the page as expected.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #11022 by arcascomputing
I believe that the language of the "you can't access this" message is the bit which is captured by your plugin as I believe in the past I used a language override to adjust the message being returned by Edocman to ensure it too was captured.

There's obviously more to it than that however.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #11024 by carsten888
thats right. The messaqge is a flag that access was denied. Redirect-on-login can work with quite a number of these messages, but when a component changes the message it stops triggering Redirect-on-Login to do its thing when no access. Most of it is language-proof.
What you can do is check the no-access message from edocman. Copy that and make a language override to say 'Please login first'. (but is seems you already tried that?)

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #11028 by arcascomputing
Hi Carsten

That's correct, I've already overridden the language for Edocman which comes from the language string EDOCMAN_LOGIN_TO_ACCESS to be "Please login first" but this was done ages ago and nothing has changed in that regard which is why I'm confused as to why the redirection is no longer taken place?

Please Log in or Create an account to join the conversation.

Time to create page: 0.135 seconds
Powered by Kunena Forum
 
spicy-sacerdotal