Due to health issues support is very limited

question-circle Admin menu manager Create a jquery Conflict with jomsocial backend 4.2.4

More
4 years 7 months ago #10487 by carsten888
I still can not reproduce this issue.

@geoffr
I mailed you.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago - 4 years 7 months ago #10489 by extonjaez
For me case, the error comes from the changes you have made between the version :
com_admin-menu-manager_v2.2.5_pro and the version 2.2.7 pro.
I have reinstalled the version 2.2.5 and i have not the error with jomsocial.
my question : there is a admin-menu-manage version 2.2.6 to test it ?
Many Thanks
best regards
Arnaud
Last edit: 4 years 7 months ago by extonjaez.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago - 4 years 7 months ago #10492 by carsten888
there where no changes between 2.2.5 and 2.2.5 :huh:

2.2.6 contained a workaround which was solving issues in all my testsites, but causing huge problems for others. So I released 2.2.7 the same day. If you want to test, the problem is with show/hiding menu-stuff via jquery.

With 2.2.7 installed, open administrator/modules/mod_adminmenumanager/javascript/subhead.js
// JavaScript Document

var JNC_jQuery = jQuery.noConflict();
JNC_jQuery(
	function($){		
		//setTimeout( "fixsubheadermargin()" , 50);
	}
);

function fixsubheadermargin(){
	var JNC_jQuery = jQuery.noConflict();
	JNC_jQuery("div .subhead").css("margin-top","0");
}

which does ..... nothing!

If you would change
//setTimeout( "fixsubheadermargin()" , 50);
to
setTimeout( "fixsubheadermargin()" , 50);
(do a hard refresh of browser cache crtl+f5)
you get the 2.2.6 version which actively tries to workaround the Joomla misstake of hardcoding height for the header. It worked fine on all my testsites, but was real bad on other sites.
Last edit: 4 years 7 months ago by carsten888.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #10495 by extonjaez
error of number, the good sentence is
"com_admin-menu-manager_v2.2.5_pro and the version 2.2.7 pro."

"For me case, the error comes from the changes you have made between the version :
com_admin-menu-manager_v2.2.5_pro and the version 2.2.7 pro.
I have reinstalled the version 2.2.5 and i have not the error with jomsocial.
my question : there is a admin-menu-manage version 2.2.6 to test it ?
Many Thanks
best regards
Arnaud"

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago - 4 years 7 months ago #10496 by extonjaez
I have installed the version v2.2.5_pro and have changed the file :
//setTimeout( "fixsubheadermargin()" , 50); to setTimeout( "fixsubheadermargin()" , 50);
and
setTimeout( "fixsubheadermargin()" , 50); to //setTimeout( "fixsubheadermargin()" , 50);
but with version 2.2.5 pro all works fine (and with version 2.2.7 reisntalled i have the issue.. :woohoo: )
Last edit: 4 years 7 months ago by extonjaez.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #10498 by carsten888

there is a admin-menu-manage version 2.2.6 to test it ?

no there is not.

Thank you helping to debug this issue. If only I could reproduce the issue I could fix it myself.

Please Log in or Create an account to join the conversation.

Time to create page: 0.118 seconds
Powered by Kunena Forum
 
spicy-sacerdotal