Due to health issues support is very limited

exclamation-circle Error with php 7.1

More
3 years 10 months ago #10718 by adoudiet
Error with php 7.1 was created by adoudiet
PHP 7.1.7 when adding or editing an item, there's the message following [] operator not supported for strings
Thanks for your help
Kind regards
Sory for my english I speek french

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #10719 by carsten888
Replied by carsten888 on topic Error with php 7.1
I'm aware of this but am experiencing problems with installing 7.1 so can't fix it for now. sorry.

Please Log in or Create an account to join the conversation.

More
3 years 7 months ago #10736 by websnooky
Replied by websnooky on topic Error with php 7.1
This is an easy fix to get things to work in PHP 7.1:

Open the file administrator/components/comadminmenumanager/helpers/adminmenumanager.php.
Go to line 481 which contains:
$column = '';//reset column if you using this elsewhere
and change it to:
$column[] = '';//reset column if you using this elsewhere

to make it an array variable. :)

That should do the trick in PHP 7.1 for this error. Not sure if anymore will popup using the component.

Greetz!

Please Log in or Create an account to join the conversation.

More
3 years 7 months ago #10737 by carsten888
Replied by carsten888 on topic Error with php 7.1
thank you. I will include that in the update later today.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #10779 by DavidBoggitt
Replied by DavidBoggitt on topic Error with php 7.1
Hi,

Don't know if this is related, but I'm getting the following in my error_log:

[17-Dec-2017 02:18:58 America/Chicago] PHP Warning: array_multisort(): Array sizes are inconsistent in /home/richards/public_html/administrator/components/com_adminmenumanager/helpers/adminmenumanager.php on line 486

This is PHP 7.0.26.

Meerry Christmas :)

Dave.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #10783 by carsten888
Replied by carsten888 on topic Error with php 7.1
is that with the latest version, which includes the before mentioned fix?

Please Log in or Create an account to join the conversation.

Time to create page: 0.143 seconds
Powered by Kunena Forum
 
spicy-sacerdotal