Everything is for free!
Shop is closed.
Due to health issues support is very limited

file Redirect to menu item using user group - Inconsistent

More
4 years 6 months ago - 4 years 6 months ago #10610 by w2kd
Running 4.02 Pro
Joomla! 3.6.5

First time the login is redirecting to the logout page.

The Users redirect set up is set to "normal". Main config is set to use usergroups

In this case the user is set to 2 user groups.
Both user groups are setup identically via a menu item redirect
and first login is setup to the same menu redirect.

Just did a retest witout having two usergroup and its the same so not related to the number of usergroups. It happens when one group is only assigned.
Last edit: 4 years 6 months ago by w2kd. Reason: more into

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #10611 by carsten888
I assume you posted this in the wrong forum. I think you are talking about Redirect-on-Login.

So you want the user on first login to be redirected to the logout page? If not, are you redirecting to a menu-item? What do you want it to do, and what is it doing now?

So what happens? Do you get an error? Where does the user get redirected to instead?

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #10612 by w2kd
Yes re Redirect-on-Login forum
I don't want any special redirect on first login

What is happen on this site is inconsistent redirects
Most of the time the redirects are working as programmed but then it does not work

We do have different users using the same user logon details up to 200 or more.

Not getting any errors - when it doesn't redirect to the menu item it redirects to the logout. It should not do this.

We do have a large number of user groups on the site if that has an effect.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #10613 by carsten888
I think this might be the problem.

We do have different users using the same user logon details up to 200 or more.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #10614 by w2kd
I've try to set the "when opening the site" to have the same setup but this did not effect it.

Have you any suggestions. I have a user details that I can supply that seems to be more repeatable in not working

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #10617 by carsten888
The problem is probably in using one account for 200 people. When a user logs out, Joomla destroys the php session, which is the unique user-identifyer. If another user is logging in right after that, with the same account, the redirect is broken.

Try disable ROL and set the login-redirect in the login module settings. See if that behaves any better.

Please Log in or Create an account to join the conversation.

Time to create page: 0.120 seconds
Powered by Kunena Forum
 
spicy-sacerdotal